2 métodos para hacer que Excel emita un sonido cuando finalice un cálculo

¿Te suena esta situación? Mientras Excel calcula una hoja o un libro, te pones a hacer otra cosa o te vas a tomar un café y te olvidas que lo has dejado calculando…. Te lo pregunto porque a mí me ha pasado muchas veces. Mientras Excel calcula, suelo revisar el correo o respondo alguna consulta en el foro y cuando termino me doy cuenta de que seguramente el cálculo ha terminado hace ya varios minutos…

¿Te gustaría que Excel te avisara con un sonido cuando termina de hacer un cálculo largo? Hoy te muestro dos formas de hacerlo:

Hacer que Excel suene con la tecla F9

Si el libro con el que trabajo es complejo suelo desactivar el cálculo automático para que me permita trabajar con fluidez. Eso significa que cuando requiero que se actualice, debo hacer el cálculo manualmente.

Y esto es precisamente lo que aprovecha el primer método, que reproduce un sonido cuando el cálculo ha finalizado.

Sigue los siguientes pasos:

  1. Pulsa Alt + F11 para mostrar el editor de VBA.
  2. Inserta un módulo nuevo haciendo clic con el botón derecho del ratón en el nombre del proyecto y seleccionando Insertar > Módulo.
  3. Una vez que has abierto la ventana de código del módulo, pega el siguiente código:
Sub Auto_Open()
    Application.OnKey “{F9}”, “Ejecuta_Sonido”
End Sub

Esto hace que la tecla F9, que es el atajo de teclado para calcular la hoja activa, se “mapée” haciendo que se ejecute la macro Ejecuta_Sonido.

  1. Pega el siguiente código en el módulo:
Sub F9Handler()
    Application.Calculate
    Beep
End Sub

Esta es la macro que se llama al pulsar la tecla F9. La primera línea calcula la hoja y la segunda emite el sonido que te avisará cuando el cálculo haya finalizado.

  1. Guarda el libro con el formato .xlsm (habilitado para macros).

Nota: para abrir el libro debes tener habilitadas las macros en tu equipo.

Hacer que Excel suene cuando se tiene habilitado el cálculo automático

En el segundo método para hacer que Excel emita un sonido cuando finalice un cálculo, se ejecuta una pequeña función personalizada cuando dos valores que se introducen en la columna A y B coinciden.

Inserta un módulo nuevo y pega el siguiente código:

Function Sonido()
    Beep
End Function
Beep es la instrucción que hace que Excel emita un sonido y que puedes utilizar en cualquier fórmula que escribas.

Imagina que quiero comparar los valores de las columnas A y B. Cuando éstos coinciden quiero que Excel emita un sonido. En caso de que no coincidan, la celda mostrará el mensaje “no coincide”.

Así es como quedaría la fórmula:

=SI(A2=B2;sonido();”No coincide”)

Resumen

Estas son solo dos formas de hacer que Excel emita un sonido cuando termina de calcular, pero hay muchas más. Si conoces alguna te agradeceré que la publiques en los comentarios.

¿Te ha resultado útil?

¡Compartir es vivir!
Sergio
 

La destreza y el perfeccionismo quizá sean las dos virtudes que me permiten ayudar a mis clientes a facilitar las tareas administrativas de sus negocios.

Haz clic aquí para dejar un comentario 0 comentarios

Escribe una respuesta:

Powered by WishList Member - Membership Software