1. Esta comunidad utiliza cookies. Si continuas utilizando nuestra comunidad estás aceptando la utilización de nuestras cookies. Más información.
  2. Se avecinan cambios en AyudaExcel.com

    Necesito que me des tu opinión sobre la nueva plantilla que estoy preparando para la web. Te muestro cinco imágenes del resultado. Solo tienes que pulsar aquí para escribir tu comentario.

  3. ¡Bienvenid@ a AyudaExcel! El foro más visitado sobre Excel en habla hispana.

    Si esta es tu primera visita, asegúrate de revisar los temas de la sección Utilización y Funcionamiento para familiarizarte con las funciones del foro. Si deseas publicar mensajes, será necesario que te Registres para que puedas dejar respuestas y crear tus propios mensajes, recuerda que es gratuito.

Suma de celdas con error

Tema publicado en 'Excel General' iniciado por ayudaexe, 8 Sep 2009.

  1. ayudaexe

    ayudaexe Invitado

    Hola, me gustaria hacerles una pregunta: es posible sumar celdas, en excel 2007, que tengan por contenido #¡VALOR!??
    Me explico: tengo una hoja excel con celdas que recogen valores de otras celdas; hay celdas que me dan de resultado #¡VALOR!?, pero me gustaria que omitiese el error y sumase el contenido de las celdas con un valor.
    Ejemplo:

    codigo valor

    uno 1
    tres #¡VALOR!
    cinco 5

    resultado 6


    Gracias de antemano, y un saludo
     
  2. cesar_manuel

    cesar_manuel Usuario

    Reg:
    12 Nov 2008
    Mensajes:
    50
    Me Gusta recibidos:
    0
    Respuesta: Suma de celdas con error

    Mira lo primero que se me ocurre es agregarle a la formula que utilizas para recoger los valores la siguiente formula al inicio.

    =si.error(toda tu formula,"")

    con esto al momento de presentarse error, te va a poner "" en vez de #¡valor!?. De esta forma podras sumar correctamente..

    Saludos
     
  3. Gerson Pineda

    Gerson Pineda Incondicional de Ayuda Excel Staff AyudaExcel

    Reg:
    30 Mar 2009
    Mensajes:
    8.036
    Me Gusta recibidos:
    1.120
    Género:
    Masculino
    Sep. argumentos:
    ,
    Respuesta: Suma de celdas con error

    ayudaexe

    =SUMA(SI(ESERROR(A1:A3),0,A1:A3))


    Saludos desde Honduras
     
  4. cesar_manuel

    cesar_manuel Usuario

    Reg:
    12 Nov 2008
    Mensajes:
    50
    Me Gusta recibidos:
    0
    Respuesta: Suma de celdas con error

    Acabo de aprender lo siguiente por parte del compañero Saileparty

    =SUMAR.SI(rango de datos,"<>#¡VALOR!?",rango a sumar)

    o puedes sustituir lo subrayado por

    =SUMAR.SI(rango de datos,"<>"&[/U]celda con el error[/U],rango a sumar)

    Saludos
     
  5. sailepaty

    sailepaty Incondicional de Ayuda Excel

    Reg:
    4 Oct 2008
    Mensajes:
    1.356
    Me Gusta recibidos:
    61
    Respuesta: Suma de celdas con error

    Intenta así,

    Si todos los valores son positivos te alcanza con esto.
    =SUMAR.SI(A1:A4;">0")

    Si tienes tambien negativos entonces.
    =SUMAR.SI(A1:A4;">0")+SUMAR.SI(A1:A4;"<0")

    Saludos
     
  6. ayudaexe

    ayudaexe Invitado

    Respuesta: Suma de celdas con error

    ok muchas gracias, lo probare y os digo que tal.

    muchisimas gracias adelantadas al foro y a todos sus colaboradores
     
  7. ayudaexe

    ayudaexe Invitado

    Respuesta: Suma de celdas con error

    OK, me ha funcionado perfecto. He utilizdo la formula SI.ERROR y ha funcionado perfecto.

    Otra pequeña consulta: es possible realizar un boton para que haga un pegar de una celdas en concreto???

    Gracias otra vez y felicidades
     

Compartir esta página