1. Esta comunidad utiliza cookies. Si continuas utilizando nuestra comunidad estás aceptando la utilización de nuestras cookies. Más información.
  2. ¡Bienvenid@ a AyudaExcel! El foro más visitado sobre Excel en habla hispana.

    Si esta es tu primera visita, asegúrate de revisar los temas de la sección Utilización y Funcionamiento para familiarizarte con las funciones del foro. Si deseas publicar mensajes, será necesario que te Registres para que puedas dejar respuestas y crear tus propios mensajes, recuerda que es gratuito.

[SOLUCIONADO] cambiar color de celda con formato condicional en función de texto.

Tema publicado en 'Excel General' iniciado por pearljam, 27 Ene 2010.

Estado del tema:
Cerrado para nuevas respuestas
  1. pearljam

    pearljam Nuevo Usuario

    Reg:
    27 Ene 2010
    Mensajes:
    5
    Me Gusta recibidos:
    0
    Hola muy buenas, tengo una duda y que no consigo resolver y es la siguiente, como puedo cambiar el color de varias celdas en funcion del texto de otra celda?
    Por ejemplo si tengo un pedido aceptado y en mi celda coloco la palabra "ACEPTADO" necesito que varias celdas se pongan de color verde y si por el contrario coloco la palabra "RECHAZADO" necesito que varias celdas se pongan de color. :confused:

    Gracias de antemano por vuestra ayuda!
     
  2. logroastur

    logroastur Incondicional de Ayuda Excel

    Reg:
    10 Oct 2009
    Mensajes:
    2.533
    Me Gusta recibidos:
    298
    Re: cambiar color de una celda a traves de un formato condicional en funcion de texto

    Buenas perljam debes de usar el formato condicional, en el debes de seleccionar por formula y colcar por ejemplo la siguiente formula
    si los datos de ACETAPTADO O RECHAZADO los ingresas en la columa A
    la formula seria asi a partir de la columna B
    en la celda B1
    en la 1º regla =SI($A1="ACEPTADO";1;0) y selecionar en la pestaña de formato, pestaña de relleno y seleccionar verde
    en la 2º regla =SI($A1="RECHAZADO";1;0) y selecionar en la pestaña de formato, pestaña de relleno y seleccionar rojo
    luego copiarias y pegarias con pegado especial, formato, en las celdas que desee que este el mismo formato

    bueno espero que hayas entendido lo explicado

    un saludo
     
  3. pearljam

    pearljam Nuevo Usuario

    Reg:
    27 Ene 2010
    Mensajes:
    5
    Me Gusta recibidos:
    0
    Re: cambiar color de una celda a traves de un formato condicional en funcion de texto

    muchas gracias logroastur! lo he entendido todo correctamente y a la primera a funcionado, todo correcto. lo malo que al hacer el pegado especial solo me lo hace en celdas normales y no en celdas combinadas pero bueno eso me lo imaginaba y de momento no me preocupa.

    Muchas gracias por la ayuda logroastur, eres un fenomeno, Un saludo!!:D.
     
  4. logroastur

    logroastur Incondicional de Ayuda Excel

    Reg:
    10 Oct 2009
    Mensajes:
    2.533
    Me Gusta recibidos:
    298
    Re: cambiar color de una celda a traves de un formato condicional en funcion de texto

    buenas de nuevo para el tema de celdas combinadas tiens dos posibilidades
    1º dividir primero las celdas pegarles el formato y luego combinarlas de nuevo
    2º selecionar cada celda combinada y realizar la labor de relizar el formato combinado de cada un de ellas
    un saludo
     
  5. CarlosB

    CarlosB Nuevo Usuario

    Reg:
    9 Mar 2010
    Mensajes:
    2
    Me Gusta recibidos:
    0
    Re: cambiar color de una celda a traves de un formato condicional en funcion de texto

    Oye pero si quiero que el formato cambie solo si hay una palabra especifica dentro de todo el texto de la otra celda?? me explico: quiero que A1 cambie de color si en B1 se encuentra la palabra "FALTA", (en B1 puede haber un texto largo dentro del cual puede o no estar la palabra "FALTA"), asi pues quiero que identifique si dentro de B1 se encuentra esa palabra, de ser asi que cambie de color. Gracias
     
  6. Julibaga

    Julibaga Usuario

    Reg:
    23 Sep 2009
    Mensajes:
    2.370
    Me Gusta recibidos:
    111
    Género:
    Masculino
    Re: cambiar color de una celda a traves de un formato condicional en funcion de texto

    En el formato condicional de A1 ponle:
    =ENCONTRAR("falta",$B$1,1)<>0

    Nota: Verifica que el separador que usas es ",". Si no, cambialo por ";"
     
  7. CarlosB

    CarlosB Nuevo Usuario

    Reg:
    9 Mar 2010
    Mensajes:
    2
    Me Gusta recibidos:
    0
    Re: cambiar color de una celda a traves de un formato condicional en funcion de texto

    Muchas gracias julibaga!! eso es precisamente lo que queria! perfecto!
     
  8. Julibaga

    Julibaga Usuario

    Reg:
    23 Sep 2009
    Mensajes:
    2.370
    Me Gusta recibidos:
    111
    Género:
    Masculino
    Re: cambiar color de una celda a traves de un formato condicional en funcion de texto

    Me alegro te sirviera.
    Ya sabes dónde encontrarnos.
     
Estado del tema:
Cerrado para nuevas respuestas

Compartir esta página