1. Esta comunidad utiliza cookies. Si continuas utilizando nuestra comunidad estás aceptando la utilización de nuestras cookies. Más información.
  2. ¡Bienvenid@ a AyudaExcel! El foro más visitado sobre Excel en habla hispana.

    Si esta es tu primera visita, asegúrate de revisar los temas de la sección Utilización y Funcionamiento para familiarizarte con las funciones del foro. Si deseas publicar mensajes, será necesario que te Registres para que puedas dejar respuestas y crear tus propios mensajes, recuerda que es gratuito.

Solucionado [SOLUCIONADO] Calcular Horas extra en formato HORA

Tema publicado en 'Temas resueltos' iniciado por Joe, 4 Jun 2009.

Estado del tema:
Cerrado para nuevas respuestas
  1. Joe

    Joe Nuevo Usuario

    Reg:
    4 Jun 2009
    Mensajes:
    4
    Me Gusta recibidos:
    0
    Buenos dias amigos

    He estado creando una hoja excel para calcular mis horas realizadas semanalmente.

    Hasta ahora lo he solucionado todo solo consultando la ayuda de excel, pero ahora mismo me encuentro atascado
    Cambie el formato de mi hoja de numero a horas y cambiando un par de cosillas me funciona todo menos las horas extra.

    La operación en la hoja anterior era la siguente :

    Celdas horas normales
    =SI(O6<8;SUMA(O6);8)

    Celdas hojas extra
    =SI(O6>8;SUMA(O6-8);)

    Eso en formato numerico me iva de categoria, pero ahora con el formato de hora no me funcciona correctamente

    El problema es que en cuanto pase de 08:00 horas se quede a 08:00 y lo demas pase a la columna de horas extras

    La verdad es que me da un poco de coraje no poder acabarlo yo, pero estoy realmente atascado

    Hoja con numeros
    Partes Joe Doughty Prueba3.xlsx

    Hoja con Horas
    Partes Joe Doughty Prueba5.xlsx

    Nota : Las lineas Q y R estarán ocultas
    Nota 2 : No me ha dejado adjuntar los archivos, los he subido a una cuenta mediafire que tengo, aqui les dejo la url para descargarlos.
     
  2. vinzent

    vinzent Usuario

    Reg:
    25 Sep 2008
    Mensajes:
    187
    Me Gusta recibidos:
    0
    Respuesta: Calcular Horas extra en formato HORA

    Hola Joe

    No he podido ver tus archivos, ya que estoy en horas de trabajo :D
    Pero te adjunto una porcion de lo que necesitas:
    -Un ejemplo de un archivo con las horas de trabajo incluyendo horas extras
    -La explicacion para calcular horas en Excel

    Solo que debido a que nada es perfecto, estan en ingles :(, pero no te preocupes dado que ya vas avanzado en el tema, solo debes checar las funciones de las formulas. Tambien puedes probar traducirlo con Mr. Google

    Si deseas descargar el archivo que explica todas las funciones entra aqui

    Ojala y te sirva para lo que necesitas.
     

    Adjuntos:

  3. Joe

    Joe Nuevo Usuario

    Reg:
    4 Jun 2009
    Mensajes:
    4
    Me Gusta recibidos:
    0
    Respuesta: Calcular Horas extra en formato HORA

    Gracias Vinzent

    Voy a hecharle un vistazo y te comento (el idioma no es problema, corre sangre inglesa por mis venas :D)

    Ahora te comento algo
     
  4. vinzent

    vinzent Usuario

    Reg:
    25 Sep 2008
    Mensajes:
    187
    Me Gusta recibidos:
    0
    Respuesta: Calcular Horas extra en formato HORA

    Si quedan resueltas tus dudas con el material que te puse, por favor solo hazlo saber para poder cerrar el tema :p
     
  5. Antonio

    Antonio Usuario

    Reg:
    29 Jun 2008
    Mensajes:
    271
    Me Gusta recibidos:
    1
    Respuesta: Calcular Horas extra en formato HORA

    Joe y Vinzent, me encontraba con un problema para calcular horas extras y efmc con su genialidad, me ayudó con una función que está de campeonato mundial. Tal vez les ayude a ustedes y por ello les adjunto el fichero que la contiene. Saludos.
     

    Adjuntos:

  6. efmc

    efmc Usuario

    Reg:
    5 Sep 2008
    Mensajes:
    571
    Me Gusta recibidos:
    5
    Respuesta: Calcular Horas extra en formato HORA

    Hola a todos.

    Joe: No he podido descargar tus archivos, pero creo que el problema es el número 8, tal como está. Excel utiliza fracciones para calcular horas, es decir, las 15:00 en realidad es 0,625 (15/24), independientemente de cómo se muestre. Esto se puede comprobar cambiando el formato de la celda de "hora" a "número".

    Así pues es muy probable que la solución sea convertir el número 8 en horas, para eso tienes dos opciones: 8/24 ó la función Horanúmero("8:0:0"):

    CÓDIGO:
    Es necesario iniciar sesión o registrarse para ver este contenido.
    Aunque también podrías utilizar:
    CÓDIGO:
    Es necesario iniciar sesión o registrarse para ver este contenido.
    respectivamente.

    Espero haber acertado con el problema. Un saludo.

    PS. las fechas también son números (parte entera), por lo que debes tener cuidado de que en los datos sólo tengas horas, no días con horas, si quieres que los cálculos sean correctos.
     
  7. Joe

    Joe Nuevo Usuario

    Reg:
    4 Jun 2009
    Mensajes:
    4
    Me Gusta recibidos:
    0
    Respuesta: Calcular Horas extra en formato HORA

    Hola a todos de nuevo, siento no haber entrado antes, tube una semana de vacaciones sin previo aviso (bajo la faena)
    Vincent el fichero que me pasastes funcciona, pero no veo como acoplarlo a mi hoja excel, ya que en la hoja que tengo esta también la opción de horas festivas entre otras cosas

    Ahora mismo estoy repasandolo y os comento que tal va, que me pilla un poco descolocado :)
     
    Última edición: 12 Jun 2009
  8. Joe

    Joe Nuevo Usuario

    Reg:
    4 Jun 2009
    Mensajes:
    4
    Me Gusta recibidos:
    0
    Respuesta: Calcular Horas extra en formato HORA

    Bueno solucionado muchisimas gracias a todos, al final lo que he puesto es lo siguiente :

    Horas normales
    CÓDIGO:
    Es necesario iniciar sesión o registrarse para ver este contenido.
    Horas Extras
    CÓDIGO:
    Es necesario iniciar sesión o registrarse para ver este contenido.
    Gracias a efmc por el codigo, y gracias a todos por la ayuda, ahora me queda dejarlo mas aseado como el de vincent pero los codigos parece que ya están al 100%

    Lo subo ya con los codigos por si a alguien le pudiera servir (tener en cuenta que hay 2 columnas ocultas Q y R)
    http://www.mediafire.com/file/ztdz5ujmydj/Partes final.xlsx
    Si teneis problemas de descargarlo y me aconsejais subirlo a otro lado no tengo problemas, pero por el foro no deja la extensión xlsx ni la rar

    De nuevo muchas gracias a todos por la ayuda
     
Estado del tema:
Cerrado para nuevas respuestas

Compartir esta página