1. Esta comunidad utiliza cookies. Si continuas utilizando nuestra comunidad estás aceptando la utilización de nuestras cookies. Más información.
  2. ¡Bienvenid@ a AyudaExcel! El foro más visitado sobre Excel en habla hispana.

    Si esta es tu primera visita, asegúrate de revisar los temas de la sección Utilización y Funcionamiento para familiarizarte con las funciones del foro. Si deseas publicar mensajes, será necesario que te Registres para que puedas dejar respuestas y crear tus propios mensajes, recuerda que es gratuito.

Solucionado Problemas con la función Si-

Tema publicado en 'Temas resueltos' iniciado por uniequivoc, 22 Jun 2009.

Estado del tema:
Cerrado para nuevas respuestas
  1. uniequivoc

    uniequivoc Nuevo Usuario

    Reg:
    22 Jun 2009
    Mensajes:
    3
    Me Gusta recibidos:
    0
    Buenos dias

    Estoy intentando hacer la programación de un club de baloncesto de 14 equipos mediante excel.

    Usando la función =si() (u otra que sirviera) desearia poder indicarme si dos celdas contienen el mismo valor:

    Ej:

    C4 i C5 = "A" --> Dar valor 1
    C4 = "A" i C5 = "B"--> dar valor 0 o 2

    gracias
     
  2. Gerson Pineda

    Gerson Pineda Moderador Staff AyudaExcel

    Reg:
    30 Mar 2009
    Mensajes:
    7.268
    Me Gusta recibidos:
    759
    Género:
    Masculino
    Respuesta: Problemas con la función Si-

    Bienvenido al foro

    Te entiendo, pero mejor pon un ejemplo xls para ver de que exactamente se trata tu asunto

    Me imagino lo que quieres hacer



    Saludos desde Honduras
     
  3. ioyama

    ioyama Moderador Staff AyudaExcel

    Reg:
    24 Jun 2008
    Mensajes:
    4.634
    Me Gusta recibidos:
    360
    Respuesta: Problemas con la función Si-

    Hola uniequivoc

    Bienvenido al foro

    =Si(A1=A2;1;2), si prefieres el cero cuando sean distintos =Si(A1=A2;1;0).

    Un saludo desde Vitoria
     
  4. uniequivoc

    uniequivoc Nuevo Usuario

    Reg:
    22 Jun 2009
    Mensajes:
    3
    Me Gusta recibidos:
    0
    Respuesta: Problemas con la función Si-

    Gracias

    De verdad que no sabia como hacerlo y habia probado muchas cosas, pero el principio de la "NAVAJA DE OCLAM" es cierto, en igualdad de circunstancias, la solución más sencilla suele ser la verdadera.

    Gracias otra vez.


    Cuando tenga listo el .xls, lo colgaré por si alguien lo necesita... je, je je :)
     
  5. uniequivoc

    uniequivoc Nuevo Usuario

    Reg:
    22 Jun 2009
    Mensajes:
    3
    Me Gusta recibidos:
    0
    Respuesta: Problemas con la función Si-

    Bueno,
    No está solucionado del todo.

    Realmente me interesaria que si coincidieran en un caràcter concreto diera un valor i en los otros casos diera otro.

    Ej:

    C5=C4="F"--> VALOR "0"
    C4= "F" Y C5="C"--> VALOR "0"
    C4= "C" Y C5="F"--> VALOR "0"
    C4=C5="C"--> VALOR "ERROR C4YC5"
     
  6. josemaria

    josemaria Usuario

    Reg:
    24 Sep 2008
    Mensajes:
    738
    Me Gusta recibidos:
    5
    Respuesta: Problemas con la función Si-

    Hola uniequivoc;

    me atrevo a interponerme en las respuestas de mis compañeros, a ver si es esto lo que quieres:

    =SI(Y(C4="C";C5="C");SI(O(C4="F";C5="C";C4="C";C5="F");"ERROR C4YC5";0);0)



    Un Saludo.
    Jose Maria.
     
  7. ioyama

    ioyama Moderador Staff AyudaExcel

    Reg:
    24 Jun 2008
    Mensajes:
    4.634
    Me Gusta recibidos:
    360
    Respuesta: Problemas con la función Si-

    Hola uniequivoc

    ¿Porqué no subes un archivo con todas las posibilidades?

    Lo digo por que la pregunta inicial no parece tener nada que ver con esta, y como probablemente las posibilidades si serán A, B, C, D, E, F...., habrá que ligar las posibles soluciones que se te den ahora, bien con la anterior, bien con una nueva especificación. ¿No?

    No obstante prueba con

    =SI(Y(C4="C";C5="C");"Error C4 y C5";SI(O(C4="F";C5="F");0;1))

    Un saludo desde Vitoria
     
Estado del tema:
Cerrado para nuevas respuestas

Compartir esta página