1. AyudaExcel utiliza cookies. Si continuas utilizando AyudaExcel, estás aceptando la utilización de nuestras cookies. Más información.
  2. ¡Bienvenid@ a AyudaExcel! El foro más visitado sobre Excel en habla hispana.

    Si esta es tu primera visita, asegúrate de revisar los temas de la sección Utilización y Funcionamiento para familiarizarte con las funciones del foro. Si deseas publicar mensajes, será necesario que te Registres para que puedas dejar respuestas y crear tus propios mensajes, recuerda que es gratuito.

Solucionado Hoja para horas de trabajo

Tema publicado en 'Excel General' iniciado por santiperez, 17 Jun 2011.

Estado del tema:
Cerrado para nuevas respuestas
  1. santiperez

    santiperez Nuevo Usuario

    Registrado:
    15 Jun 2011
    Mensajes:
    6
    Me Gusta recibidos:
    0
    necesito saber como hacer un excel en donde me calcule las horas trabajadas en una jornada laboral partida teniendo dos horas de entrada y otras dos de salida,de donde me deduzca las horas totales trabajadas,las horas extras, teniendo en cuenta que la jornada es de ocho horas,y que apartir de las 22:00 son horas dobles.me gustria que los resultados me los diera en numeros naturales,no en fraciones horarias. me podeis ayudar? GRACIAS

    Adjuntos:

  2. logroastur

    logroastur Incondicional de Ayuda Excel

    Registrado:
    10 Oct 2009
    Mensajes:
    2.522
    Me Gusta recibidos:
    295
    Buenas chequea archivo


    un saludo

    Adjuntos:

  3. santiperez

    santiperez Nuevo Usuario

    Registrado:
    15 Jun 2011
    Mensajes:
    6
    Me Gusta recibidos:
    0
    hola logroastur!!
    gracias por ayudarme.
    en la suma total falta una hora;suma una hora de menos
    gracias
  4. logroastur

    logroastur Incondicional de Ayuda Excel

    Registrado:
    10 Oct 2009
    Mensajes:
    2.522
    Me Gusta recibidos:
    295
    Buenas cambia la formula de la columna F por

    CÓDIGO:
    =SI(B16="";"";SI(D16<>0;(RESIDUO(B16-E16;1)-RESIDUO(D16-C16;1));RESIDUO(C16-B16;1)))
    un saludo
    Última edición: 21 Jun 2011
  5. santiperez

    santiperez Nuevo Usuario

    Registrado:
    15 Jun 2011
    Mensajes:
    6
    Me Gusta recibidos:
    0
    hola de nuevo logroastur!
    siento comunicar que las formulas me siguen fallando.
    sigue calculando mal las horas totales;las extras(a partir de 8 horas) y las dobles(a partir de las 22:00 horas).
    gracias
    un saludo

    Adjuntos:

  6. logroastur

    logroastur Incondicional de Ayuda Excel

    Registrado:
    10 Oct 2009
    Mensajes:
    2.522
    Me Gusta recibidos:
    295
    Buenas es conveniente que se realice estudio de las aportaciones para entender estas,

    el error era en el tras toque de orden

    en la columna F usa

    CÓDIGO:
    =SI(B16="";"";SI(D16<>0;(RESIDUO([B][COLOR=red]E16-B16[/COLOR][/B];1)-RESIDUO(D16-C16;1));RESIDUO(C16-B16;1)))
    en columna G usa

    CÓDIGO:
    =SI(B16="";"";SI(F16>8/24;F16-8/24;""))
    siempre y cuando las horas dobles no deban de ser descontadas las horas extras sino fuese así y se debiesen de descontar usar
    CÓDIGO:
    =SI(B16="";"";SI(F16>8/24;(F16-8/24)-SI(H16="";0;H16);""))
    en columna H usa
    CÓDIGO:
    =SI(MAX(B16:E16)>22/24;MAX(B16:E16)-22/24;"")
    siempre y cuando no importe que no se huviesen realizado horas extras pero si qe se pase de las 22:00, si no fuese así sino que se precise que haya horas extras para tener encuenta el horario de las 22:00, usa

    CÓDIGO:
    =SI(Y(MAX(B16:E16)>22/24;F16>8/24);MAX(B16:E16)-22/24;"")
    un saludo
  7. santiperez

    santiperez Nuevo Usuario

    Registrado:
    15 Jun 2011
    Mensajes:
    6
    Me Gusta recibidos:
    0
    gracias por el aporte.
    otra duda!!
    como se hace para que cuente las extras asta las 22:00 y apartir de esa hora que cuente todo en extras dobles asta las 8 de la mañana que empezaría una nueva jornada
  8. logroastur

    logroastur Incondicional de Ayuda Excel

    Registrado:
    10 Oct 2009
    Mensajes:
    2.522
    Me Gusta recibidos:
    295
    buenas cheque archivo

    observa en los nombres definidos esta creado el horario a contemplar como horario nocturno o doble

    un saludo

    Adjuntos:

  9. santiperez

    santiperez Nuevo Usuario

    Registrado:
    15 Jun 2011
    Mensajes:
    6
    Me Gusta recibidos:
    0
    gracias
    eres un FENOMENO!!!!
    funciona ok!
Estado del tema:
Cerrado para nuevas respuestas

Compartir esta página