1. AyudaExcel utiliza cookies. Si continuas utilizando AyudaExcel, estás aceptando la utilización de nuestras cookies. Más información.
  2. ¡Bienvenid@ a AyudaExcel! El foro más visitado sobre Excel en habla hispana.

    Si esta es tu primera visita, asegúrate de revisar los temas de la sección Utilización y Funcionamiento para familiarizarte con las funciones del foro. Si deseas publicar mensajes, será necesario que te Registres para que puedas dejar respuestas y crear tus propios mensajes, recuerda que es gratuito.

Formula para calcular trienios

Tema publicado en 'Excel General' iniciado por jose_manuel69, 29 Oct 2008.

  1. jose_manuel69

    jose_manuel69 Nuevo Usuario

    Registrado:
    21 Oct 2008
    Mensajes:
    5
    Me Gusta recibidos:
    0
    Antigüedad Nombre Fecha Actual trienio trienio
    16/10/2005 a 29/10/2008 3 ??
    02/10/2002 b 29/10/2008 6
    19/10/1999 c 29/10/2008 9
    06/10/1996 d 29/10/2008 12


    teniendo esos datos como puedo crear una formula que me de los resultados que he introducido manualmente en la fila trienio ??

    El objetivo es obtener todas aquellas personas que cumplan en el mismo mes un trienio, bien sea, 3-6-9-12-15 y descartar el resto ya que son bastantes.

    Gracias.
    Última edición: 29 Oct 2008
  2. sailepaty

    sailepaty Incondicional de Ayuda Excel

    Registrado:
    4 Oct 2008
    Mensajes:
    1.356
    Me Gusta recibidos:
    58
    Esta formula te regresa la palabra No en caso de el empleado no sea su trienio aniversario. En caso de que sea te regesa los años.

    =SI(RESIDUO(SIFECHA(A1;B1;"Y");3);"No";SIFECHA(A1;B1;"Y"))

    Saludos
  3. Nicotuc

    Nicotuc Moderador Staff AyudaExcel

    Registrado:
    26 Ago 2008
    Mensajes:
    1.221
    Me Gusta recibidos:
    78
    Prueva con la formula:
    =(DIAS360(A1;C1;VERDADERO))/360
    Esto teniendo en cuenta que la fecha inicial este en la celda A1 y la fecha final en la celda C1 y lo divido en 360 que son los dias del año

    Luego en la columna F1 pon:
    =MULTIPLO.INFERIOR(E1;3)
    Esto suponiendo que la formula anterior la pusiste en la celda E1. Lo que hace esto es redondear el resultado anterior a 3 o multiplos de 3 (de forma que si te da 7 u 8 lo redondea a 6; si da 10 u 11 lo redondea a 9)

    Espero haberme hecho entender. Cualquier cosa me avisas
  4. Nicotuc

    Nicotuc Moderador Staff AyudaExcel

    Registrado:
    26 Ago 2008
    Mensajes:
    1.221
    Me Gusta recibidos:
    78
    Completando lo que expuse arriba puedes colocar en la celda G1:

    =SI(E1<>F1;" ";"CUMPLE TRIENIO")

    Esto requiere que la columna E1 tenga dos o mas decimales. Y lo que hace es comparar los trenios que tiene y si los cumple en esa fecha.

    Cualquier cosa silva

Compartir esta página