1. Esta comunidad utiliza cookies. Si continuas utilizando nuestra comunidad estás aceptando la utilización de nuestras cookies. Más información.
  2. ¡Bienvenid@ a AyudaExcel! El foro más visitado sobre Excel en habla hispana.

    Si esta es tu primera visita, asegúrate de revisar los temas de la sección Utilización y Funcionamiento para familiarizarte con las funciones del foro. Si deseas publicar mensajes, será necesario que te Registres para que puedas dejar respuestas y crear tus propios mensajes, recuerda que es gratuito.

Solucionado Contar.si. Es mayor que y menor que

Tema publicado en 'Excel General' iniciado por pcourtois, 23 Ago 2011.

Estado del tema:
Cerrado para nuevas respuestas
  1. pcourtois

    pcourtois Usuario

    Reg:
    6 Abr 2009
    Mensajes:
    101
    Me Gusta recibidos:
    0
    Saludos

    Necesito que la formula CONTAR.SI() pueda aplicarla a un criterio <6 y >=4, es decir que me cuente todos los 4 y 5

    Gracias por la colaboración
     
  2. Gerson Pineda

    Gerson Pineda Moderador Staff AyudaExcel

    Reg:
    30 Mar 2009
    Mensajes:
    7.079
    Me Gusta recibidos:
    684
    Género:
    Masculino
    Hola
    Sera algo asi:

    =CONTAR.SI($A$1:$A$10,5)+CONTAR.SI($A$1:$A$10,4)

    Veo tambien que tienes version 2007, busca CONTARSICONJUNTO (aqui en mi trabajo solo dispongo de 2003)

    Saludos desde Honduras
     
    Última edición: 23 Ago 2011
  3. Cacho R

    Cacho R Incondicional de Ayuda Excel

    Reg:
    18 Jul 2011
    Mensajes:
    1.305
    Me Gusta recibidos:
    38
    Hola! pcourtois.
    Complementando lo mencionado por Gerson (a quien le envío un gran saludo), tienes dos opciones:

    a) Le envías a los ingenieros de Microsoft una nota pidiéndoles que la función CONTAR.SI haga una cosa distinta de aquello para lo que fue diseñada; o

    b) Buscas opciones. Una de ellas ya te la menciona Gerson. Otra variante es:

    CÓDIGO:
    Es necesario iniciar sesión o registrarse para ver este contenido.
    Saludos, Cacho R.
     
  4. Gerson Pineda

    Gerson Pineda Moderador Staff AyudaExcel

    Reg:
    30 Mar 2009
    Mensajes:
    7.079
    Me Gusta recibidos:
    684
    Género:
    Masculino
    Cacho! que bueno saludarte de nuevo... pero no crees que SUMAPRODUCTO ponga lento a don Excel si son miles/millones de datos?... por esa razon no la recomiendo siempre

    Saludos
     
  5. Ama

    Ama Usuario Activo

    Reg:
    21 Nov 2008
    Mensajes:
    901
    Me Gusta recibidos:
    41
    Hola pcourtois

    Puedes usaar la función "Sumaproducto":
    Si los datos están en el rango A1:A15
    Si solo se puede usar la función "Contar.Si" ,a ver si te puede servir así:

     
  6. Cacho R

    Cacho R Incondicional de Ayuda Excel

    Reg:
    18 Jul 2011
    Mensajes:
    1.305
    Me Gusta recibidos:
    38
    ¡Pero Gerson!...
    A1:A10 (rango por ti propuesto) no son millones de celdas...
    ¡Te lo aseguro!... ¡Créeme!... (jejejeje)
     
  7. Gerson Pineda

    Gerson Pineda Moderador Staff AyudaExcel

    Reg:
    30 Mar 2009
    Mensajes:
    7.079
    Me Gusta recibidos:
    684
    Género:
    Masculino
    jeje es correcto, pero solo es para un ejemplo, (pcourtois debe adjuntar uno), pues no sabemos que cantidad de datos va a leer con las formulas, me entiendes? siempre pensando un poco en cantidades grandes de datos, recuerda que aqui solo se solicita un fragmento

    Saludos
     
  8. Cacho R

    Cacho R Incondicional de Ayuda Excel

    Reg:
    18 Jul 2011
    Mensajes:
    1.305
    Me Gusta recibidos:
    38
    Mi estimado Gerson
    Por ser vos te doy un 50% y 50%... O sea:

    a) Es cierto que pcourtois no dio referencia alguna sobre la cantidad de datos sobre los que desea operar. Pero...

    b) Eso de "... grandes cantidades de datos ..." me suena inconsistente con la permanente prédica sobre que si se manejan grandes cantidades de datos, entonces lo que conviene es trabajar con bases de datos y no con Excel, aún si de la versión 2010 habláramos...

    Esto es como quien tiene un Fiat 600 y te dice: - " Le bajé la suspensión y me dio 132 km/h en ruta "...

    ¿No lo crees?...
    Saludos, Cacho R.
     
  9. Gerson Pineda

    Gerson Pineda Moderador Staff AyudaExcel

    Reg:
    30 Mar 2009
    Mensajes:
    7.079
    Me Gusta recibidos:
    684
    Género:
    Masculino
    Cacho estamos de acuerdo! pero tu panorama/experiencia/conocer exceliano te deja ver lo que nos comentas, mi criterio no va en contra de tu aporte, si no va para SUMAPRODUCTO

    Saludos
     
  10. Gerson Pineda

    Gerson Pineda Moderador Staff AyudaExcel

    Reg:
    30 Mar 2009
    Mensajes:
    7.079
    Me Gusta recibidos:
    684
    Género:
    Masculino
    Hola pcourtois, te hemos ayudado en algo?

    Saludos
     
  11. Cacho R

    Cacho R Incondicional de Ayuda Excel

    Reg:
    18 Jul 2011
    Mensajes:
    1.305
    Me Gusta recibidos:
    38
    Gerson:
    Te propongo que si pcourtois no nos brindara su parecer en el transcurso de las siguientes doce horas, sigamos hablando de automóviles antigüos... ¿Qué tal?.
     
  12. pcourtois

    pcourtois Usuario

    Reg:
    6 Abr 2009
    Mensajes:
    101
    Me Gusta recibidos:
    0
    Gracias a todos por su siempre acostumbrada atención a los temas.
    Es correcta la observación de que no coloqué rango, será una columna completa, por decir $A$A$, ya que puede contener quince celdas con datos o pudieran ser las 1048576 celdas de Excel 2007.
    No había respondido porque la tabla la tengo en la oficina y actualmente estoy en mi casa, pero mañana les comento como me fue, lo mas seguro es que utilicé el aporte del amigo Gerson =CONTAR.SI($A$1:$A$10,5)+CONTAR.SI($A$1:$A$10,4) es el que mas se me asemeja a lo que busco.

    A todos Gracias por sus aportes, eso es lo que nos destaca como comunidad dentro de la red, la participación siempre oportuna.

    Saludos

    --- Mensaje unido automáticamente ---

    Definitivamente es esa la opción Gerson.
    Muchas Gracias y saludos a todos
     
Estado del tema:
Cerrado para nuevas respuestas

Compartir esta página